PDA

View Full Version : How do I turn off autorun


The Mad Monk
04-07-2005, 04:16:17
in windows XP?

I don't mean the menu that lets you tell the computer what to do when somebady sticks a music CD in it (I've already nailed that). I mean the autorun "feature" that lets games and other software throw up (and I do mean barf) a splash screen / menu and otherwise have their way with your system when you put a program CD in it.

I know it can be done, I did away with it on my Win98 box ages ago, but I've given up finding it on XP.

I'm not above hacking the registry to rid myself of this vermin, either.

So how about it?

The Mad Monk
04-07-2005, 04:20:22
I did find an autorun.exesomethingsomethingsomething.pf, but simply deleting it seems too obvious and risky.

Gary
04-07-2005, 08:47:36
Open up explorer, right click on the drive, chose properties, Autoplay tab.

Trying fiddling with the drop down menu and "actions to perform". It isn't instinctive, which I assume is deliberate nastiness on the part of MS, rather than incompetence, but my guess would be to set it for mixed content to take no action ?

Whatever, play with the settings and see what they do.

The Mad Monk
04-07-2005, 17:54:18
Already been there and done that.

The options there are for:

Music files
Pictures
Video files
Mixed content
Music CD
DVD movie
Blank CD

...in that order.

Notice how "executables" or "program files" or anything else like that is very absent.

No, "mixed content" isn't it, either.


Here's an example, from just last night:

I had purchased the "Very Best of Fleetwood Mac" album, and put it in the drive for the very first time. My jukebox program and a game were already running.

After a minute the dialogue box asking me what I wanted to do with the CD came up on cue, just as I had set it, but before I could click on anything a half formed splash screen pops up and my cursor goes funky -- trails on the screen, you know the drill -- and everything grinds to a near halt.

I manage to bring up the task manager, and what do I see taking up 90+% of the CPU cycles?

FLEETWOOD.EXE.

Without my knowledge, without my permission, and before the system could ask me if I even wanted to play the damn CD, it INSTALLED and EXECUTED a program on MY SYSTEM.


I want this "feature" OFF my system NOW.

No longer Trippin
05-07-2005, 04:29:53
Disable mixed content. You have media files on the disk as well, so it should treat it as such.

The Mad Monk
22-08-2005, 16:30:30
I tried that. I disabled everything on that window. It didn't work. I checked it again after you suggested it. It still didn't work

Obviously, they want a backdoor major manufacturers can use to force unwanted programs down our throats. I want to find that door and spike it shut.

Any other ideas?

Sir Penguin
22-08-2005, 23:45:54
Find the following entry in the registry:

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Services\ CdRom

Click on it, find the AutoRun key, and set its value from 1 to 0.

SP

Sir Penguin
22-08-2005, 23:47:46
The TweakUI Powertoy will also do that for you.

SP

The Mad Monk
23-08-2005, 05:17:04
Yes! YES!! It's dead! It troubles me no more! OOOOO-RAH!!!

Once again, SP swoops in to save my sanity!

:bounce: THANK YOU! :bounce: