View Full Version : Speeding up Firefox on broadband

07-02-2005, 10:27:27
This seems to work.

From http://www.w2knews.com ....

* Run Firefox? Have broadband? Here's Speed Tips

Here's something for broadband people that will really speed up

1.Type "about:config" into the address bar and hit return.
Scroll down and look for the following entries:
Normally the browser will make one request to a web page at a
time. When you enable pipelining it will make several at once,
which really speeds up page loading.

2. Alter the entries as follows:
Set "network.http.pipelining" to "true"
Set "network.http.proxy.pipelining" to "true"
Set "network.http.pipelining.maxrequests" to some number like 30.
This means it will make 30 requests at once.

3. Lastly right-click anywhere and select New-> Integer. Name
it "nglayout.initialpaint.delay" and set its value to "0". This
value is the amount of time the browser waits before it acts
on information it receives. If you're using a broadband
connection you'll load pages MUCH faster now!

07-02-2005, 12:38:11
So did you actually try this?

07-02-2005, 12:39:02
Yes, hence my comment that it seems to work.

07-02-2005, 13:43:26
Thanks !!!! :beer:

07-02-2005, 13:59:11
It really is amazingly much faster isn't it.

07-02-2005, 15:51:52
How come you have a space between about and :config, and that link hasn't?

07-02-2005, 15:57:03
hey, it works.

and my internet speed was doubled by my provider yesterday.

07-02-2005, 15:57:07
I don't know, I just copied and pasted it from the link. Weird.

Immortal Wombat
07-02-2005, 16:23:39
It still doesn't make 'poly load quickly...

07-02-2005, 17:10:05

smart browser

Sir Penguin
07-02-2005, 21:32:05
It can cause problems though (that's why it's disabled by default).


07-02-2005, 21:36:44
such as?

07-02-2005, 21:56:22
From one of the lead Firefox dev's blog:

After seeing at least a couple dozen blog posts all referencing these changes to "speed up Firefox", I thought it would be worth a little explanation.

Yes, enabling HTTP pipelining can dramatically improve networking performance. The downside, and the reason it's not enabled by default, is that it can prevent Web pages from displaying correctly. If you've enabled this, and you find pages that aren't displaying correctly, please don't blame Firefox or the Web developer. It's probably the fact that you enabled an "unsupported" feature which is incompatible with some Web servers and proxy servers.

The second change, setting the initial paint delay at zero, may get you some content on the screen faster, but it's worth noting that it will dramatically slow down the time it takes the entire page to display. Here's what's going on. Gecko, Firefox's rendering engine, is trying to optimize between the cost of waiting for a bit more data versus doing more painting and reflows as new data comes in. Waiting a bit longer before it starts painting the page gives Gecko a chance to receive more content before chewing up CPU cycles to render and reflow the document. If you drop this value down to zero or near zero, that means you'll see the page start displaying a bit earlier, but not having received much data in that short interval, you'll have a lot more paint and reflow cycles to complete rendering of the page.

This one probably comes down to a combination of bandwidth, CPU speed, and personal preference. If it works for you, and you don't mind the side-effects, then great. Just note that what works for one person/system, may not work for another.

Yes, there are tuning change you can make (even at compile time, see Moox' optimized builds) that will dramatically alter the performance characteristics of Firefox. Feel free to experiment, but remember that most of the defaults are defaults for a reason. If your browser starts misbehaving or web sites look broken, it might be worth going back to default settings.

08-02-2005, 09:25:50
Cool. Thanks Asher.

It does seem to be much faster so far and no problems as yet.

08-02-2005, 14:10:55
Websites look funny with firefox anyway, buttons on CG moving around and all.

But when i checked today, the settings were back to the old situation. How do you save the settings?

08-02-2005, 17:48:10
Tried it and it seems the same.

08-02-2005, 22:49:09
FYI (http://secunia.com/multiple_browsers_idn_spoofing_test)

Or to go straight to the test (http://www.paypÓl.com/)

Ah... the direct to the test one doesn't really have the same result as going via the other page.

Sir Penguin
09-02-2005, 04:21:25
To fix the problem in Firefox, you open up about:config and toggle the "network.enableIDN" value to False (by right-clicking on it and selecting the "toggle" option). It means that you can't visit sites that legitimately use international characters in their domain names, but nobody who counts uses those anyway.


Sir Penguin
09-02-2005, 07:14:16
Another option to toggle to False is "browser.blink_allowed", which disables the <blink> tag.


09-02-2005, 08:19:04

Sir Penguin
09-02-2005, 21:39:25
And here's a better fix for Firefox:


Basically, it's hard-coding it into a configuration file to make the change permanent.


Sir Penguin
10-02-2005, 02:05:19
And here's an even better one (the last one will be reset every time you install or uninstall an extension):


It requires Adblock, and I guess it blocks everything from any site with a non-ASCII character in its name.


24-02-2005, 16:29:45


24-02-2005, 16:30:21
:lol: :lol:

27-02-2005, 21:54:26
What, did he steal that thread here? That's rich. Or did funko steal his from somewhere?

27-02-2005, 22:06:16
Fred Stolen