PDA

View Full Version : Linux for Dummies...


Jeratain
31-10-2003, 06:40:37
Hello. Okay, first let me state that I have only used Linux from downloading ISO files and I am still pretty much a total newbie at it - I do not claim to know anything about it, but I want to learn :) That said, I'm having a very basic and idiotic problem. I have Windows XP on my main harddrive and have downloaded Mandrake onto it (details below.) I have another harddrive I am going to add as a slave drive so I can install this Linux distro on, but I've run into this little scab.

I went to download Linux distrobution of Mandrake 9.2 from a USC FTP server. After a day I finally finished getting all the necessary files onto my harddrive. Unfortunately, the FTP didn't offer the usual ISO files that I so would have preferred to download. Instead I downloaded the entire contents of the i586 files which turned out to be 2.53 GB worth of files from this FTP server: ftp://mirrors.usc.edu/pub/linux/distributions/mandrake/9.2/i586/ (if you go there you can see the files that I now have on my hardrive).

Now the issue I am having is that I have no idea how to go about installing Linux from these files. They aren't in ISO format so I can't directly burn the files to a CD without knowing what files and folders go to which CD. The Mandrake folder itself contains most of the files so it equates to roughly 2.5 gigs. Is there anyway to go about this, or am I going to have to download the ISO files from someplace else?

If you can't access the FTP server, the folders I have on my computer are as follows:

>i586
>i586>doc
>i586>dosutils
>i586>images
>i586>isolinux
>i586>lang
>i586>Mandrake
>i586>misc

You can view the actual contents and subfolders at the above listed FTP.

Any help is appreciated :)

Deacon
31-10-2003, 07:11:52
I'm not that familiar with Mandrake. I did find the following page...

ftp://mirrors.usc.edu/pub/linux/distributions/mandrake/9.2/i586/install.htm

Maybe you could try the "other installation methods" section. It sounds as simple as writng images/hd.img to a floppy and rebooting.

Sir Penguin
31-10-2003, 07:28:06
It looks like i586/ is the root directory for the install CD. You would have to copy the directory tree starting there onto a CD, burn one of the floppy images from i586/images onto a disk (depending on what the readmes and install.html files say), and boot from that disk. The disk should in turn lead to the installation from CD.

They haven't released the public ix86 Mandrake 9.2 ISOs yet.

SP

Sir Penguin
31-10-2003, 07:36:07
Originally posted by Deacon
It sounds as simple as writng images/hd.img to a floppy and rebooting.

It might be able to do a network install from the floppy, but... well, Debian needs four floppies to do that. :)

SP

Jeratain
31-10-2003, 08:49:28
Fuck it, I've made my life too complicated. I just left it to download while I was out studying and ended up with that, and then realized what a mistake/waste of bandwidth that was - 2.5 GB will sit there until I actually do what you guys suggest or if something else clicks in my head.

Meanwhile I've began downloading RedHat 9 like the little Linux wanabe poser I am - and THIS TIME I'M GETTING THE ISO FILES so I don't have to deal with this shit again.

Thanks for the tips though.

Sir Penguin
31-10-2003, 09:47:29
It's the same thing as Mandrake anyway.

SP

Deacon
31-10-2003, 20:52:03
If Mandrake is the way I remember it, then Mandrake likes to release more bleeding-edge stuff than Red Hat.

Deacon
31-10-2003, 21:25:20
http://www.linuxiso.org/

Jeratain
01-11-2003, 05:44:50
Thanks, I have that site bookmarked :)

Actually, I went ahead and downloaded both Mandrake 9.1 and RedHat 9 in ISO forms and burned them to CDs.

I tried out Mandrake first and ran into a similar snag 4 times in a row.

I boot from CD ROM, set up the partitions (on a slave drive dedicated to Linux, so there's no quarrels with the native Windows drive) and begin the installations with standard packages (workstation, graphics, games, programmer, server, and I forget which others).

Anyhow, the install starts out fine with the files and it asks me to put CD 2 in and it continues off fine, but when I get down to roughly 1 or 2 minutes left in the install the CD ROM slows down and stops. I leave it for about 10 miutes and find it in the same position. The CD ROM light gives a flash every few seconds, but isn't making any actual noise and the hard drive is not writing. I try to click on cancel or details or even eject the CD, but the CD ROM has stopped responding - even to the manual eject button.

So I have to restart.

Basically this is getting annoying as it has happened 4 times now. The installation process is so simple, only I can't get this wicked file to write for the last package... I've attempted to single out the package which it froze on and remove it from install, but then it just freezes on another package at the end instead - the occurances are random I believe. And no, I am not running an LG CD ROM.

Oh well, I'll give RedHat a shot now.

Sir Penguin
01-11-2003, 09:08:13
Have you tried re-burning CD2? My Windows XP CDs are kind of like that. One can't start and the other can't finish, but together they get just about everything (except sptip.dll, whatever that is).

SP

Jeratain
01-11-2003, 09:55:21
I'm sortof against wasting another CD, but I'll give it a shot :P

Sir Penguin
01-11-2003, 10:09:10
:lol:

Give me your address, I'll send you a frigging CD.

SP

Jeratain
02-11-2003, 01:37:19
Okay, now this is ridiculous. I have attempted to install both Linux Mandrake 9.1 and Redhat 9 - both have given me the same issues.

I figure that it's the packages I choose to install. I go through the first CD on both of them fine, and then after I put in the second CD and install more packages for the first 5 minutes it begins to slow down and then eventually freezes up.

One method of bypassing this freezing is to eject the CD from the tray and insert it again, then it just skips the package it was on, but it continues to fail for the next package as well.

I DID make another copy of CD 2 for Mandrake (I even burned it at a much slower speed so it wouldn't be sloppy) however this was to no avail. I got the exact same issue.

Oh, and here's the beauty of it all. I figured that maybe it was my computer hardware causing problems (you know, my CD ROM or something) so I threw the hard drive into another system with a different processor, ram, CD drive, etc - IT DID THE SAME CRAP!

I checked the ISO files using one of those file checker tools and they checked out just fine.

The only possibilities I can come up with is that perhaps the CD-Rs I use just plain old suck - but if that were the case, why would CD 1 work fine :confused: And the other is that perhaps the hard drive I am using is faulty in one way or another... I don't have a spare hard drive to allocate space for Linux, so I can't test this on other ones - at least not yet.

I WILL figure this out.

EDIT: Also, another possibility is that I should just lay off installing any packages at first. I should just go ahead and install the base OS and networking stuff and leave the rest for later. But I want it all at once!!! :)

Sir Penguin
02-11-2003, 02:41:18
Failing that, it might be worth trying Debian (http://www.debian.org). It uses a different package management system and a different installer.

SP

chagarra
03-11-2003, 09:20:20
Might be worth noting......


"Mandrake has warned users of its Mandrake Linux 9.2 to beware of a "severe problem" which totally trashes CD drives by overwriting their firmware.

The issue is caused when the kernel that ships with Mandrake Linux 9.2 and early updates sends a FLUSH_CACHE command to the CD drive. For "certain" CD drives manufactured by LG, this command overwrites the firmware and renders the drive useless."



http://www.theregister.co.uk/content/54/33648.html

Jeratain
03-11-2003, 09:25:50
Thanks, but I actually looked into that. I don't use an LG CD drive and I was attempting Linux 9.1 from the CDs since I only had 9.2 on the harddrive. Oh well :(

Qaj the Fuzzy Love Worm
03-11-2003, 15:57:22
Originally posted by Sir Penguin
Failing that, it might be worth trying Debian (http://www.debian.org). It uses a different package management system and a different installer.

SP

You're recommending Debian for a self-confessed Linux newbie, SP? Are you some kind of sadist? :D Debian doesn't exactly have a reputation as easy to install and learn with.

Sir Penguin
03-11-2003, 20:54:38
Debian Potato was my first distribution. :)

I'd recommend Red Hat to a newbie any day, except the day when the install doesn't work. I'm just thinking that since Debian's installation and package management paradigms are different from the Red Hattish distros, it might be worth checking out.

Having said that, I would probably also recommend Debian to a newbie who "want[s] to learn", in parallel with Red Hat. Red Hat's good if you want to see results quickly and easily. Debian's good if you want to run into walls and search for the doors.

SP

Deacon
03-11-2003, 22:44:11
Debian is nice. I switched to it after tryng Suse, Redhat, and Mandrake in succession. What I really liked about Debian was its approach to the config files and init scripts. And APT handles dependencies, so there's no fumbling with RPMs, trying to figure out which ones to install first. The update-rc.d script is so nice that I "stole" it and changed a few lines so it would work with Linux From Scratch.

Testing is about the right mix between stability and newness. Stable is okay for those who can tolerate oldness.