PDA

View Full Version : Sim City 4


Asher
13-01-2003, 04:44:21
I just installed the game and the fucker won't run.

It installed fine, but when I launch the program nothing happens! It uses CPU for a couple seconds and sucks up 12MB of RAM, and the process stays open for about 60 seconds but I never see a window or anything.

After that 60s it crashes without saying why.

I've tried about 4 different video card drivers.

I think it may not like DirectX 9.

Nav
13-01-2003, 09:38:48
DirectX 9 is still in beta right? There's your problem.

Asher
13-01-2003, 15:24:44
No, the final was released last week. So was WMP9.

Other people on other forums have the exact same problem with DirectX 8 too. So that rules that out...

golden light of the forum
15-01-2003, 04:34:31
Hey Ash - this posted at CGN. Same deal...

Sim City 4
I just bought it today. I haven't played yet though because it wont work It doesn't do anything when I run the program other than make noise like it is running something for just a minute.

Asher
15-01-2003, 04:47:02
I got it fixed, the problem was SafeDisc.

DaemonTools has a SafeDisc emulator, it works when I use that. :b:

golden light of the forum
15-01-2003, 05:38:56
With some help from the scc people, and wise I fixed the problem. Something about running it in software mode. You have to edit the simcity.ini file in the Apps folder in the simcity4 folder (which I was stupid and couldn't find ). just add 2 semi colons and it worked.

make it look like this:


quote:
--------------------------------------------------------------------------------
[Graphics Drivers]
;OpenGL =SimGLRef.dll, C4554841
Software=SimGLSoft.dll,7ACA35C6
;D3D7 =SimGLDx7.dll, BADB6906
--------------------------------------------------------------------------------



instead of this:


quote:
--------------------------------------------------------------------------------
[Graphics Drivers]
OpenGL =SimGLRef.dll, C4554841
Software=SimGLSoft.dll,7ACA35C6
D3D7 =SimGLDx7.dll, BADB6906

--------------------------------------------------------------------------------



At first the screen got scrambled and gave me some message about using software mode instead of hardware mode. Then sc4 was "not responding". Then I tried it again and it worked


So far the game is pretty good. The tutorial is nice. I have a much better idea of how to play sim city than I did playing sc3000 and sc2000. Graphics are really good I think too. You can even see the little oranges on the trees!

golden light of the forum
15-01-2003, 05:39:37
oh, you got it fixed i see...not sure if what I posted (from the same girl that had the earlier problem) was the solution, but doesn't matter now I suppose.

BoltyBoy
15-01-2003, 09:37:42
You can even see the little oranges on the trees!

You mean you see them as in it's an orange coloured pixel right?

DaShi
15-01-2003, 14:50:11
Do the trees change color during the seasons?

golden light of the forum
15-01-2003, 22:21:47
Originally posted by BoltyBoy
You mean you see them as in it's an orange coloured pixel right?

no idea, the post was from a CGN member...

but the irony of this quote is striking

golden light of the forum
15-01-2003, 22:22:23
Originally posted by DaShi
Do the trees change color during the seasons?

how the hell should I know? I just work here...

BoltyBoy
16-01-2003, 01:06:01
What's God's middle name?

golden light of the forum
16-01-2003, 07:35:30
M-e-y-e-r